安装使用

环境要求如下:

PHP >= 7.1.0

1. 通过composer安装

composer require wansh/thinkeasyadmin

建议使用国内镜像(阿里云), 因为国外的可能比较慢

composer config -g repo.packagist composer https://mirrors.aliyun.com/composer/

2. 引入使用

创建一个后台控制器 并且继承 \easyadmin\controller\Admin 即可

#project\app\admin\controller\Category.php
 
namespace app\admin\controller;
 
 
class Category extends \easyadmin\controller\Admin
{
 
}

如果您的数据库配置正确,并且存在数据表category,您将会看到如下界面: